mysteriöse Rechtecken im Cursorbreich

Alles was mit Swing und AWT zu tun hat

Moderatoren: wegus, Olek77

Jaqen H'ghar
Beiträge: 2
Registriert: 07.01.2018, 16:56

mysteriöse Rechtecken im Cursorbreich

Beitragvon Jaqen H'ghar » 07.01.2018, 18:32

Hallo zusammen,

Hat jemand eine Idee woher dieses Rechteck sein könnte.

rechteck.PNG
rechteck.PNG (10.11 KiB) 763 mal betrachtet


Ich endecke es immer wieder auf manchen Swing Komponenten, wenn sich der Mauszeiger auf darauf ausruht. Es scheint aber irgendwie als ob es willkürlich im Gui Builder erzeugt wird, denn lösche ich die Komponennte, z.B ein JButton oder JLabel und erzeuge sie neu ist es wieder weg. Manchmal aber auch nicht.
Ich habe auch schon beobachtet, dass das Rechteck machmal wieder verschwindet wenn ich den Text entferne oder nur den Hintergrund ändere. Total unlogisch, ist das ein Bug in Netbeans?? Wäre ja nicht der einzige, machmal habe ich auch komische Grafik Erscheinungen die den Quelcode überdecken. Bin ich der einzige mit solchen Problemen?

ich nutze Version 8.2

MfG

Benutzeravatar
nigjo
Beiträge: 597
Registriert: 08.09.2009, 09:43
Wohnort: Aachen
Kontaktdaten:

Re: mysteriöse Rechtecken im Cursorbreich

Beitragvon nigjo » 08.01.2018, 08:06

Hi

Das sieht nach einem Tooltip aus. Ist im GUI-Builder unter Properties etwas unter "toolTipText" eingetragen? Möglicherweise nur ein Leerzeichen. Wenn "toolTipText" fett geschrieben ist, solltest du vielleicht mal im Kontextmenü "Restore Default Value" aufrufen.

Gruß
Jens
Man sollte seine Werkzeuge kennen. Ansonsten haut man sich mit dem Hammer nur auf die Finger.

--
NetBeans Certified Engineer - Java Getriebe

Jaqen H'ghar
Beiträge: 2
Registriert: 07.01.2018, 16:56

Re: mysteriöse Rechtecken im Cursorbreich

Beitragvon Jaqen H'ghar » 08.01.2018, 10:58

Super, danke Dir!!!
Scheinbar reicht es wenn man nur in das toolTipText-Feld in den Properties klickt, damit der GUI-Builder die Zeile jKomponente.setToolTipText(""); erzeugt.
Da habe ich wohl öfter mal aus Versehen ins falsche Feld geklickt. Aber mit Reset to Default passt es dann wieder. :-)


Zurück zu „Java - Swing/AWT“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 3 Gäste