IDE Mausbedienung und Linux

Alles zur oder um die NetBeans IDE

Moderator: wegus

Benutzeravatar
jann
Beiträge: 50
Registriert: 18.09.2008, 19:34
Wohnort: Winsen (Aller)
Kontaktdaten:

IDE Mausbedienung und Linux

Beitragvon jann » 26.04.2015, 12:15

Hallo,

ich habe NetBeans auf meinem Linux-Laptop (Linux-Mint) installiert, leider funktioniert die Bedienung mit der Maus nicht so wie zu erwarten wäre.

Ich kann mit der Maus die IDE fast normal bedienen. Wo die Maus nicht funktioniert, sind die Untermenüs. Klicke ich beispielsweise im Hauptmenü auf -File- dann klappt das Untermenü raus; will ich dann mit der Maus einen Menüpunkt anklicken geht, das nicht, Ich muss im Untermenü mit den Pfeiltasten (+Enter) den gewünschten Menüeintrag auswählen.

Ich habe das Verhalten bei NetBeans 7.4 und 8.0.

Kennt jemand das Problem und eine Lösung?

Gruß, Jann

Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

Re: IDE Mausbedienung und Linux

Beitragvon wegus » 27.04.2015, 09:33

Nein, so kenne ich das eigentlich nicht. Aber das normale Lokk&Feel ist unter LINUX eh nicht besonders gut. Mein Tipp wäre in Deinem Netbeans-Verzeichnis im dortigen Unterverzeichnis etc die Datei netbeans.conf zu suchen und darin eine Zeile die wie folgt beginnt:

Code: Alles auswählen

netbeans_default_options="...


vor dem abschließenden Anführungszeichen füge bitte einfach folgendes ein:

" --laf Nimbus"

dasw verwendet ein anderes Look & Feel und könnte die Probleme evtl schon beheben!?
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!

Benutzeravatar
smurfi
Site Admin
Beiträge: 1615
Registriert: 29.06.2006, 11:33
Wohnort: Wuppertal
Kontaktdaten:

Re: IDE Mausbedienung und Linux

Beitragvon smurfi » 28.04.2015, 05:17

Hallo,

welche Linux-Mint Version benutzt du denn?
Unter Ubuntu treten die Probleme nicht auf, und soweit ich mich erinnere war bis zu einer gewissen Mint Version der unterbau ja Ubuntu.

Gruß
Michael

Benutzeravatar
jann
Beiträge: 50
Registriert: 18.09.2008, 19:34
Wohnort: Winsen (Aller)
Kontaktdaten:

Re: IDE Mausbedienung und Linux

Beitragvon jann » 28.04.2015, 13:26

Vielen Dank!

Wie es so oft ist, man muss erst mal die Frage richtig formulieren und findet dann auch eine Antwort ;-)

Fündig geworden bin ich in der englischsprachigen NetBeans-Community (bugzilla):

https://netbeans.org/bugzilla/show_bug.cgi?id=227754

Der Fehler lässt sich beheben, in man im Netbeans-Startscript "export DESKTOP_SESSION=gnome" einfügt. Gemacht, getan - funktioniert.

Unter ubuntu hatte ich das Problem nicht, nur mit Linux-Mint, so wie es auch im Bug-Report steht.

Besten dank für die Hilfe, Jann

P.S.: das Problem tritt bei mir unter Linux Mint Mate 17 auf

Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

Re: IDE Mausbedienung und Linux

Beitragvon wegus » 29.04.2015, 07:26

OK Danke, wieder was gelernt!
Unter Gnome3/Debian und Ubuntu 14.04 LTS kannte ich den Effekt nicht!
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!


Zurück zu „NetBeans - IDE“

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast