end of file seen before seeing a doctype first

Alles was die PHP erweiterung von NetBeans betrifft

Moderator: wegus

Antworten
Benutzeravatar
wegus
Beiträge: 458
Registriert: 26.09.2006, 09:07

end of file seen before seeing a doctype first

Beitrag von wegus » 18.01.2012, 10:43

ich habe gerade mal Netbeans 7.1 begonnen zu testen und da bekomme ich bei zahlreichen Dateien die obige Warnung. Die ist nun an den Stellen leider falsch weil die PHP-Dateien die die IDE bemängelt hier Include-Dateien sind und daher gar keinen doctype benötigen. Ich schätze die recht pingeligen Warnungen von Netbeans bezüglich HTML-Fehlern sehr und möchte die HTML-Validierung daher eher nicht inaktivieren.

Kann mir jemand sagen woran Netbeans meint festzustellen das die PHP-Datei einen Doctype braucht und andere eher nicht? Es gilt ja nicht pauschal für jede PHP-Datei das ein Doctype nötig ist. Das requiren von nötigen Klassen und Header-Dateien ist ebenfalls nicht ungewöhnlich, also wird es da doch eine Lösung geben oder?
Wenn etwas zu einfach klingt um wahr zu sein, dann ist es oft auch nicht wahr!

Antworten