Seite 1 von 1

Module können nicht aktiviert werden

Verfasst: 28.11.2016, 11:44
von raptor49
Ich habe Suse Leap 42.2 /64 am laufen und NB 8.2 installiert. Allerdings lassen sich die Module nicht aktivieren. Sämtliche JRE, JDK und OpenJDK sind installiert.

Bild

Bei Funktionen aktivieren kommt:

Aktivierung nicht erfolgreich. Das JDK fehlt, wird aber für die Ausführung einiger Netbeans Module benötigt.


Was soll denn da fehlen? :shock:

Re: Module können nicht aktiviert werden

Verfasst: 28.11.2016, 15:09
von wegus
Den selben blöden Bug hatte ich unter Ubuntu auch! Der Pfad zum JDK in der netbeans.conf stimmt nicht!

Bei mir war es für Ubuntu und das oracle JDK:

Code: Alles auswählen

netbeans_jdkhome="/usr/lib/jvm/java-8-oracle"

Re: Module können nicht aktiviert werden

Verfasst: 28.11.2016, 15:45
von raptor49
In der Datei kann ich das aber nicht bearbeiten, warum auch immer.

EDITH. Bearbeiten kann ich jetzt, aber er speichert es nicht.

Re: Module können nicht aktiviert werden

Verfasst: 29.11.2016, 08:24
von wegus
ja, ein Zugriffsrechteproblem. Wer hat installiert? Wer darf dort schreiben? Das anpassen und dann klappt das auch!

Du mußt aber vorher eh gucken, wie der Pfad bei Dir heissen muß!!

Re: Module können nicht aktiviert werden

Verfasst: 29.11.2016, 13:22
von raptor49
Ich hab ja Zugriff, aber es funzt trotzdem nicht. NB nimmt oder erkennt einfach den Pfad nicht.

Re: Module können nicht aktiviert werden

Verfasst: 29.11.2016, 14:13
von wegus
vielleicht weil er bei Dir anders lautet!?

Was gibt denn

Code: Alles auswählen

echo $JAVA_HOME


bei Dir aus?

Re: Module können nicht aktiviert werden

Verfasst: 29.11.2016, 15:04
von raptor49
Klar lautet der Pfad anders, aber daran lag es gar nicht. Scheinbar ging bei der Installation von NB was schief. Hab grad NB Neu installiert und jetzt funzt alles.

Außerdem:

Code: Alles auswählen

/usr/lib64/jvm/java


Bei 64 bit ist der Pfad anders.

Thema erledigt. :mrgreen:

Re: Module können nicht aktiviert werden

Verfasst: 30.11.2016, 07:26
von wegus
Ja natürlich lautet der Pfad anders, da Du kein Ubuntu benutzt (bei mir ist das der 64Bit Pfad wie von mir angegeben)! Und ja na klar ist der bei der Installation falsch eingetragen worden (gerade das ist ja der Bug). Den richtigen Pfad hättest Du aber auch ohne Neuinstallation eigentlich nur in die conf-Datei schreiben brauchen. Aber egal: Hauptsache jetzt löpt et!

Re: Module können nicht aktiviert werden

Verfasst: 30.11.2016, 14:16
von nigjo
wegus hat geschrieben:Den selben blöden Bug hatte ich unter Ubuntu auch! Der Pfad zum JDK in der netbeans.conf stimmt nicht!

Bei mir war es für Ubuntu und das oracle JDK:

Code: Alles auswählen

netbeans_jdkhome="/usr/lib/jvm/java-8-oracle"

Man kann den Wert auch in seinem Userdir ändern. Dazu muss innerhalb des Userdir ein Verzeichnis "etc" angelegt werden in dem dann eine "netbeans.conf" erstellt wird. In dieser Datei reicht es "netbeans_jdkhome" zu setzen, der Rest wird automatisch aus der "netbeans.conf" im Installationsverzeichnis verwendet. Sollte auf allen Betriebssystemen funktionieren.

Gruß
Jens