Problem deploying NB 6.7 Project in NB 6.8

J2EE, JSP, JSF, VisualWeb-Pack usw.

Moderator: wegus

Antworten
philipp.abromeit
Beiträge: 1
Registriert: 01.03.2010, 12:19

Problem deploying NB 6.7 Project in NB 6.8

Beitrag von philipp.abromeit » 01.03.2010, 12:24

Hallo!
Ich habe auf 6.8 geupdated und deploye meine Enterprise Application jetzt auf dem GF3. Seitdem bekomme ich, wenn ich aus NB heraus deploye folgenden Fehler:

Deployment error:
null
See the server log for details.
at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:205)
at org.netbeans.modules.j2ee.ant.Deploy.execute(Deploy.java:103)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:288)
at sun.reflect.GeneratedMethodAccessor476.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:597)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:357)
at org.apache.tools.ant.Target.performTasks(Target.java:385)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1337)
at org.apache.tools.ant.Project.executeTarget(Project.java:1306)
at org.apache.tools.ant.helper.DefaultExecutor.executeTargets(DefaultExecutor.java:41)
at org.apache.tools.ant.Project.executeTargets(Project.java:1189)
at org.apache.tools.ant.module.bridge.impl.BridgeImpl.run(BridgeImpl.java:278)
at org.apache.tools.ant.module.run.TargetExecutor.run(TargetExecutor.java:498)
at org.netbeans.core.execution.RunClassThread.run(RunClassThread.java:151)
Caused by: java.lang.NullPointerException
at java.io.Win32FileSystem.compare(Win32FileSystem.java:576)
at java.io.File.compareTo(File.java:1852)
at java.io.File.compareTo(File.java:120)
at java.util.TreeMap.put(TreeMap.java:545)
at java.util.TreeSet.add(TreeSet.java:238)
at java.util.AbstractCollection.addAll(AbstractCollection.java:305)
at java.util.TreeSet.addAll(TreeSet.java:295)
at org.netbeans.modules.glassfish.javaee.ResourceRegistrationHelper.getResourceDirs(ResourceRegistrationHelper.java:104)
at org.netbeans.modules.glassfish.javaee.ResourceRegistrationHelper.deployResources(ResourceRegistrationHelper.java:85)
at org.netbeans.modules.glassfish.javaee.ide.FastDeploy.initialDeploy(FastDeploy.java:121)
at org.netbeans.modules.j2ee.deployment.impl.TargetServer.deploy(TargetServer.java:623)
at org.netbeans.modules.j2ee.deployment.devmodules.api.Deployment.deploy(Deployment.java:170)
... 16 more

Hat jemand eine Idee, woran das liegen kann bzw., wie man dieses Problem wieder beheben kann? Wenn ich bsplsw. über die GF Admin-Console deploye gibt es kein Problem. Ich bin für jeden Hinweis dankbar.

Gruß Philipp

Antworten